Jump to content

On_The_Edge79

New Member
  • Content Count

    2
  • Joined

  • Last visited

About On_The_Edge79

  • Rank
    New Member
  1. On_The_Edge79

    Sync3, car play and vehicle camera freezing.

    Thanks for the reply and info Jimbo! I’ll give that a shot later on and let you know what happens. I’m shocked I didn’t read or think of that myself. It Kinda makes sense. Ford should start paying productive members in forums for helping others fix their vehicles. 😉
  2. Hello, I took delivery of my ST in December 2018. Pretty much 1 month into ownership sync 3 has been glitchy. When I start the car and then plug my phone into the dock to access car play the screen will turn blue and freeze. The only fix I could find for this was rebooting the system holding power and the right arrow. This works every time but is quite annoying. Another thing it’s doing which may or may not be related is when I’m in the car play menu and I back up the camera switches over like it’s supposed to but freezes and or switches to the front camera while I’m driving. So so with that out of the way, I took it to the dealer yesterday and after 3-5 try’s they updated the software and said that was the cause for my freezing issues. I tried it before leaving the parking lot, pretty close to closing time and what do you know it’s still freezing. I went back in and they tried blaming my phone cord which happened to be brand new for the issue. I told them BS, they came back and said they will talk to Ford but there may not be a fix for this. Has as anyone had issues or experience like this? Just paid 50k for a car and a few months into ownership this is how I’m treated. This is after spending 50k on an F-150 in 2015. Is there anyway to bypass the dealer and deal with Ford directly?
×