Jump to content
eddie368

ST Transmission

Recommended Posts

Does any of you ST owners dislike the way the 8 speed transmission works?In drive it works OK !  But in Sport it is soft and slow shifting.Sometimes it down shifts and some times it don't.Accelerate thur the gears and let off the gas and instead of upshifting it starts down shifting and rev matching. Shift paddles does not a performance car make.I would  think very hard before buying one  again.

Share this post


Link to post
Share on other sites

My car was built 12/9/18 and in Drive it shifts well but not very sporty. In sport it shifts very fast and maintains the perfect gear for instant power. The slightest tap of the throttle will toss everyone back in their seats and I often see the traction control light come on. Very fun to drive with no odd shifting in either mode. 

Share this post


Link to post
Share on other sites

No issues here. In Sport mode it keeps the revs up. The trick is to plan ahead - the same way you would with a manual - math you corner get your gear, etc...

As for paddle shifters - well Ford and all other brands don't seem to have engineers that actual drive the cars as performance vehicles.  I think BMW and Merc are

two companies that make their engineers get in the car with a professional driver to see what they are missing.

I have had three cars with paddle shifters and I thin they would be better used for radio volume control 😁

Share this post


Link to post
Share on other sites

I’m having an issue in drive when I hit around 5th and 6th gear it’s hesitating and then revs high and shifts hard it’s got a big leg when that happens,  I have the 2.7L 8 speed not to happy I have 9000km already had to do rotors I treat mine like a baby I love it but hate I already have issues I just traded in my 17 F150 lariat special edition had water leak and electrical issues if anyone has had this issue please let me know if there was a fix it’s frustrating!! 

Share this post


Link to post
Share on other sites

Please ask your Dealer to perform the TSB for this issue. There is a software update that should fix this. Read the part about 'Does the customer complain about harsh/bumpy upshifts...'. You need to almost verbatim make that statement. There are no codes for this TSB. The dealer doesn't need to drive... you just need to complain. Should be a 15min process for them to flash your PCM.

 

 

TSB_Edge.jpg

Share this post


Link to post
Share on other sites

I just had to have my PTU cooler replaced at 1082 miles. Backed out of garage and say drips in the floor. Went and checked and then crawled under and saw trans coolant all over the exhaust.

Took to dealer and four days later got it back. He tried replacing th seal but Ford does not have a seal that fits. So the entire cooler was replaced.

 

Now I 'm not sure if he flashed the PCM but I think not because it does seem a lot more "jerky" than it was before I took it in. It could still be in the learning phase.

 

Thanks for info BobY - I will keep on eye out for this.

Share this post


Link to post
Share on other sites

@BobY thanks for the info on that I will show this to the dealership and get them to do it it’s getting worse after my 10 hour round trip up north this past weekend. I have to have me wheels warrantied as well the finish in 4 month has faded so bad there is no shine barely left to them!! 

Share this post


Link to post
Share on other sites

I finally got my transmission issues resolved. In the end it was a torque converter replacement. So far so good. I have about 150 miles on it since and it drives 1000X better. No bucking or clunks into gear and seems to put more power down (maybe TC wasn't locking up). If anyone else is getting bucking at low speed driving right after shifting to 3rd I highly recommend you don't ignore it. Have the dealer disable the lockup solenoid and if it no longer bucks you might need a new TC. 

 

Trans Warranty Repair.jpg

Share this post


Link to post
Share on other sites

Funny you mention the clunking... since we had ours reprogrammed it shifted well until recently.  Now, intermittently, it clunks BADLY when shifting from park to drive (or reverse) or from drive to park.  No error codes thrown and I thought maybe my wife wasn't fully engaging the brake but she has and it still happens, but not all the time or reproduce-able to get service and waste that time.  Thoughts/suggestions?

Share this post


Link to post
Share on other sites

Nevermind, I see this is still a known issue that Ford is investigating.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×