Jump to content

Recommended Posts

Hello,

Last month, I brought my 2019 Ford Edge ST in for transmission issues (clunks when switching from park to drive or reverse / switching from drive to reverse or reverse to drive, vehicle jerks when up-shifting/down-shifting [mainly 3rd gear], delayed take-off, vehicle moves/rocks after switching from drive/reverse to park, etc.) I was told this is an electronic issue and the dealership reprogrammed the transmission. This lasted a couple of weeks before having issues again. I do not understand how this is an electronic issue for clunking when switching from park to drive/reverse after startup or vehicle moves/rocks after switching from drive/reverse to park and shutting off vehicle. Is there anyone else having same/similar transmission problems, and if so, was you able to fix the problem? What options do I have for this serious problem?

Thank you kindly in advance.

Share this post


Link to post
Share on other sites

The latest TSB is 20-2190.

Released June 2, 2020.

I had it done and all the issues have been resolved.

No more slow engagement from 3-4.

No more harsh engagement from R to D.

No more lurching at 6 mph when upshifting.

It looks like Ford did a really good job on this one.

I am just curious to see how long it will last.

The last TSB only lasted 4 months.

 

Pete...

Edited by MENINBLK

Share this post


Link to post
Share on other sites
On 6/17/2020 at 6:45 PM, MENINBLK said:

The latest TSB is 20-2190.

Released June 2, 2020.

I had it done and all the issues have been resolved.

No more slow engagement from 3-4.

No more harsh engagement from R to D.

No more lurching at 6 mph when upshifting.

It looks like Ford did a really good job on this one.

I am just curious to see how long it will last.

The last TSB only lasted 4 months.

 

Pete...

TSB 20-2190 corrected the same transmission issues on my 2019 ST.  However, I feel that there are still significant transmission shifting problems when attempting to shift manually with the paddles in the S mode. I find it impossible to achieve acceptable manual shifts from 2nd to 3rd to 4th under moderate acceleration in the S mode using the paddles.   Can you perform acceptable shifts in this same situation?  If so, at what RPM or speed are you shifting?  I don't know if it is only my car or if all ST's exhibit the same problem.   It almost seems like the paddles are only intended for use during heavy loaded or towing situations and not spirited driving.  

Share this post


Link to post
Share on other sites

Hi All

 

I notices similar problems to Gooney's issues.

 

Last month, they performed a TSB 8F57 diagnostic and the reflash fixed our problem.

 

Thanks

 

CVCashmere

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×